Known problems and solutions

This topic lists all known problems that you may encounter while using R‑Cloud, along with their solutions.

Restoring individual files ends with errors or failures

Problem

When a restore of individual files completes, the status of the corresponding task is Done with errors or Failed. The closer inspection reveals that some or all of your selected resources have not been restored.

Cause

The original disk no longer exists, or the credential group that is assigned to the original instance in R‑Cloud includes a user account with insufficient privileges.

Solution

Restore your files to an alternate location on the original instance, to a custom location on a different instance, or to an available bucket, or update the configuration of the credential group that is assigned to the original instance in R‑Cloud.

Inability to change the protection set or to sign in

Problem

Although you have access to Google Cloud projects that are included in multiple protection sets in R‑Cloud, only the currently selected protection set is available in the Protection set UI context. After your web user interface session ends, you are unable to sign in again.

Solution

Contact HYCU Support.

Problem with sorting data in the Events panel

Problem

In the R‑Cloud web user interface, sorting data in the Events panel by the Message parameter does not function properly.

Solution

There is no solution available for this problem. If data disappears while being sorted, sign out of the web user interface and sign in again to repopulate the table with data.

Backup of an entity is suspended

Problem

The backup of an entity is suspended, and the following event is triggered:

The backup cannot be started for <EntityName>. The automatic cleanup of expired backups must be done first. The backup will be started after the cleanup task completes.

Cause

When the RPO defined in the policy that is assigned to the entity is shorter than the time that is required to perform a backup, the backup is delayed so that the automatic cleanup of expired backups can be done first.

Solution

No action is required. The backup will be started after the cleanup task completes.

To avoid triggering this event, make sure that the RPO defined in your policy is not shorter than the time that is required to perform a backup. For details about policies, see Defining your backup strategy.

Inability to set up manually created Google Cloud targets

Problem

When you try to set up a manually created target, R‑Cloud reports that the target is inaccessible.

Solution

In the Google Cloud Storage service, grant your the Storage Admin role on the Google Cloud project of the target.

For information on the required roles for the general use of the service, see Signing in to R‑Cloud.

Assigning a policy to a Google Cloud instance fails

Problem

After adding the hycu‑policy custom metadata tag to an instance in Google Compute Engine, no policy is assigned to the instance in R‑Cloud.

Cause

The symptom may indicate one of the following:

  • The instance belongs to a Google Cloud project that is not included in any protection set.

  • The policy that is specified for the metadata tag value does not exist.

Solution

Find the corresponding entry in the event log to identify the root cause of the problem:

  1. In the R‑Cloud web user interface, go to the Events panel and search for the following error message:

    Failed to assign a policy

  2. Click the message entry, check the Message details section for the root cause of the problem, and act accordingly.

Snapshot creation fails for instances in a specific Google Cloud project

Problem

When a backup task for any instance in a specific Google Cloud project is started, the snapshot creation task fails and reports an error.

Solution

In Google Compute Engine, grant your the Compute Admin role on the Google Cloud project.

For information on the required roles for general use of the service, see Signing in to R‑Cloud.

Task progress indicator remains at 0% during the backup of a Google Cloud instance

Problem

You experience one of the following symptoms:

  • When you start a backup task, its child task for creating disk catalog never makes any progress.

  • After you start a backup or restore task, the task gets started, but it never makes any progress.

Solution

Check if the Google Cloud project that the instance belongs to has the Cloud Pub/Sub API enabled. If it does not, enable the API for the project through the Google Cloud Console.